Как увеличить размер шрифта в 1с 8.2

Казалось бы тривиальная задача — увеличить шрифт в 1С 8.2. Можно уменьшить разрешение рабочего стола, что не всегда есть гуд. Можно увеличить шрифт в Windows. Тоже свои минусы, отразится везде. Да и в терминальном режиме с этим туго, особенно в Windows Server 2008 R2.

Начинаем выкручиваться:
На примере БП 2.0 и УТ 10.3

В КОНФИГУРАТОРЕ:

1) Добавить регистр сведений «СтилиПользователей»
Непериодический, независимый
Измерения:
— Пользователь ,тип СправочникСсылка.Пользователи
Ресурсы:
— НомерСтиля   ,тип Число 1.0

2) В ветке «Общие — Стили» скопировать стиль «Основной» в «Основной1».
В стиле «Основной1» изменить Шрифт текста на Verdana,8
(путем проб можно другой подобрать, я остановился на этом)

3) В модуле обычного приложения добавить функцию ПолучитьНомерСтиляПользователя()
и вызов ее в процедуре ПередНачаломРаботыСистемы()

//+ASG
Функция ПолучитьНомерСтиляПользователя()

Запрос = Новый Запрос;
Запрос.Текст =
«ВЫБРАТЬ
|    СтилиПользователей.НомерСтиля
|ИЗ
|    РегистрСведений.СтилиПользователей КАК СтилиПользователей
|ГДЕ
|    СтилиПользователей.Пользователь = &Пользователь»;

Запрос.УстановитьПараметр(«Пользователь», ПараметрыСеанса.ТекущийПользователь);
Результат = Запрос.Выполнить().Выбрать();
Если Результат.Следующий() Тогда
Возврат Результат.НомерСтиля;
Иначе
Возврат 0;
КонецЕсли;

КонецФункции // ПолучитьНомерСтиляПользователя

// Процедура — обработчик события «Перед началом работы системы».
//
Процедура ПередНачаломРаботыСистемы(Отказ)

УправлениеПользователями.ПроверитьВозможностьРаботыПользователя(Отказ);

ГлавныйСтиль = БиблиотекаСтилей.Получить(ПолучитьНомерСтиляПользователя()); //+ASG

КонецПроцедуры

В РЕЖИМЕ 1С Предприятие:
1) В регистр «СтилиПользователей» («Операции — Регистры сведений — Стили пользователей)
прописать тех пользователей кому нужно покрупнее установив номер стиля = 1

На все уходит минут 15, правда придется «Включить возможность изменения»
в «Конфигурация — Поддержка — Настройка поддержки»

Источник: http://infostart.ru/public/153181/

Запись опубликована в рубрике Программирование и сопровождение 1с. Добавьте в закладки постоянную ссылку.

Один комментарий на «Как увеличить размер шрифта в 1с 8.2»

  1. сергей говорит:

    Подскажите пожалуйста
    Невозможно добавить стиль и увеличить шрифт в 1С 8.2
    Мои действия
    Конфигуратор конфигурация открыть конфигурацию базы данных общие стили правая кнопка мыши поле серое
    Или через регистр сведений добавить Стили пользователей правая кнопка мыши серая ?
    Что я делаю не так?

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

*

code