У текущего пользователя нет доступных ролей, для запуска информационной базы

Эта ошибка возникает при добавлении нового пользователя с новой ролью.

Например иногда необходимо в бухгалтерию добавить пользователя занимающегося кадрами и поэтому нужно для него создать новый интерфейс и роль «кадры». После чего присваиваем новую роль пользователю и пытаемся войти в 1С. Но не тут то было и 1С нам говорит, что «У текущего пользователя нет доступных ролей, для запуска информационной базы»

Для избежания этого необходимо немножко дописать в конфигураторе.

Общие — Общий модуль -УправлениеПользователями

Процедура ПроверитьВозможностьРаботыПользователя(Отказ) Экспорт
Если НЕ РольДоступна(«ПолныеПрава») И НЕ РольДоступна(«Бухгалтер») И НЕ рольДоступа(«Кадры») Тогда
Отказ = Истина;
#Если Клиент Тогда
Предупреждение(«У текущего пользователя нет доступных ролей, для запуска информационной базы.», 10, «Недостаточно прав доступа»);
#КонецЕсли
КонецЕсли;
КонецПроцедуры

После чего, применяем новую конфигурация и спокойно заходим в 1С.

Однако есть и одно но — это обновление конфигураций, после которого может произойти затирание этой записи.

Запись опубликована в рубрике Программирование и сопровождение 1с. Добавьте в закладки постоянную ссылку.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Solve : *
14 + 14 =